Over heating

General Chat About Electrics, And Ignition Systems.

Moderator: phpBB2 - Administrators

Post Reply
paulsv8manta
Helpful or Confused
Helpful or Confused
Posts: 127
Joined: Sun Nov 29, 2009 6:09 pm
Location: Eastleigh

Over heating

Post by paulsv8manta »

Hi guys here’s an interesting problem for you.
Took the sd1 3.5 v8 flapper for an MOT, unfortunately the engine overheated which seemed to put it into limp mode now I’m sure the ecu which is the early 4cu doesn’t have this function. Anyway I pulled the ecu overnight to clear the errors took it for a 15 mile run with no problems, turned it off and left it for 10 mins then restarted it to find it back in limp mode. When I say limp mode the symptoms are as follows:- engine won’t rev any higher than 2200rpm if I floor the pedal it starts to splutter coughs & revs drop right off.
This seems to be happening every time the engine gets hot, I’ve added bonnet scoops which has helped I’m not sure what else I can do. Anybody got any ideas?
Forgot to mention I have an electric fan, exhaust headers are also wrapped.



DaveEFI
Gold Member
Gold Member
Posts: 4328
Joined: Fri Feb 26, 2010 4:27 pm
Location: SW London, UK

Re: Over heating

Post by DaveEFI »

Flapper is pure analogue. No error codes to clear, no limp home mode. A typewriter rather than word processor. :D

First make sure the ignition is good. The amp on the DLM dizzy is notorious for faults.

Next, check the CTS, AFM and fuel pressure.
Dave
London SW
Rover SD1 VDP EFI
MegaSquirt2 V3
EDIS8
Tech Edge 2Y

paulsv8manta
Helpful or Confused
Helpful or Confused
Posts: 127
Joined: Sun Nov 29, 2009 6:09 pm
Location: Eastleigh

Re: Over heating

Post by paulsv8manta »

Hi dave,
I’ve checked the amp which was ok but have made a bigger heat sink for it with ducted air flow over it. CTS and AFM both reading good. I’m really hoping it was the amp.
I’m so seriously thinking about converting to Megasquirt! It’s been a year since being on the road and have only just covered 700 miles really p*****g me off!

DaxLaxV8
Newbie
Newbie
Posts: 8
Joined: Tue Mar 12, 2019 7:54 pm

Re: Over heating

Post by DaxLaxV8 »

Paul
I run the same engine, some tuning, and I have experienced overheating due to an airlock. I follow this routine:-
Remove pressure cap
Put cabin heater on full temperature and fan
Start engine and watch for air bubbles
When no more air bubbles, top up water level, don't forget antifreeze
Replace pressure cap and run engine, you may lose some water from the pressure overflow
Repeat procedure, until all air bubbles has been expelled.

paulsv8manta
Helpful or Confused
Helpful or Confused
Posts: 127
Joined: Sun Nov 29, 2009 6:09 pm
Location: Eastleigh

Re: Over heating

Post by paulsv8manta »

Cheers Dave I’ll give it a try, fingers crossed!

DaveEFI
Gold Member
Gold Member
Posts: 4328
Joined: Fri Feb 26, 2010 4:27 pm
Location: SW London, UK

Re: Over heating

Post by DaveEFI »

I'd say you need to find out for sure if the misfire is fuel or spark related. An exhaust gas analyser?
The temperature the engine is at when it happens easier to find out?
Dave
London SW
Rover SD1 VDP EFI
MegaSquirt2 V3
EDIS8
Tech Edge 2Y

GDCobra
Helpful or Confused
Helpful or Confused
Posts: 116
Joined: Sat Feb 04, 2017 9:21 am
Location: North West

Re: Over heating

Post by GDCobra »

How's the fuel pressure?

stevieturbo
Forum Contributor
Forum Contributor
Posts: 3671
Joined: Sat Nov 18, 2006 6:22 pm
Location: Northern Ireland

Re: Over heating

Post by stevieturbo »

Is this repeatable ? ie can you have this problem apparent at home, where you can test things ?

How do the plugs look after a period of running with this problem ?

If it was largely an ignition problem the plugs could be wet, sooty, etc

There are various ignition testers you could have installed on the system to watch to see the spark during the problem.

Fuel pressure as suggested shouldnt be too hard to check, or with a basic meter injector pulse width/frequency during the problem to see if it is some sort of deliberate controlling action, or the injectors may be receiving a perfectly normal signal....indicating the problem is elsewhere.
9.85 @ 144.75mph
202mph standing mile
http://www.youtube.com/watch?v=XgWRCDtiTQ0

paulsv8manta
Helpful or Confused
Helpful or Confused
Posts: 127
Joined: Sun Nov 29, 2009 6:09 pm
Location: Eastleigh

Re: Over heating

Post by paulsv8manta »

I believe I have found the problem. I have just recently fitted a sump pan and I think this has reduced the air flow around the engine substantially causing heat in the engine bay compartment to rise significantly. Since removing it I’ve had no problems looks like I need to rethink the design of the sump pan.

Post Reply

Return to “Electrical & Ignition Area”