Hello

Please introduce yourself to everyone and say hi :-)

Moderator: phpBB2 - Administrators

Post Reply
Neilr
Newbie
Newbie
Posts: 10
Joined: Thu May 11, 2017 7:21 am
Location: Barnet Herts

Hello

Post by Neilr » Thu May 11, 2017 10:48 am

Just thought I say hi I have a 71 Rover 3500 P6. Have done quite a bit of work to it recently but still it doesn't run right. Hope someone on hear can help. Neil


Rover 3500 V8

User avatar
scudderfish
Site Admin
Site Admin
Posts: 297
Joined: Sat Feb 28, 2009 6:53 pm
Location: Harpenden, Hertfordshire

Post by scudderfish » Thu May 11, 2017 4:26 pm

Hello! Photos, and a description of your problem(s)?

Regards,
David

Neilr
Newbie
Newbie
Posts: 10
Joined: Thu May 11, 2017 7:21 am
Location: Barnet Herts

Post by Neilr » Thu May 11, 2017 7:34 pm

scudderfish wrote:Hello! Photos, and a description of your problem(s)?

Regards,
David
Problem is wont run without choke. Have so far rebuilt carbs and fuel pump changed cam followers and timing chain. Tried electronic ignition. And its still the same.
Rover 3500 V8

User avatar
Rossco
Moderator Gold
Moderator Gold
Posts: 786
Joined: Sun Nov 19, 2006 11:33 am
Location: Too many to even keep count

Post by Rossco » Thu May 11, 2017 8:01 pm

Hi and welcome to the mad house

If the followers were worn then the cam will also be worn, Rover V8's are notorious for cam wear.

Rossco
F Type......the new BL Allegro

Neilr
Newbie
Newbie
Posts: 10
Joined: Thu May 11, 2017 7:21 am
Location: Barnet Herts

Post by Neilr » Fri May 12, 2017 7:29 am

Rossco wrote:Hi and welcome to the mad house

If the followers were worn then the cam will also be worn, Rover V8's are notorious for cam wear.

Rossco

The worn cam was replaced with a new 3.9 cam from V8Tuner.
Rover 3500 V8

Post Reply

Return to “Please Tell Us About Yourself”