4.6 operating temp.

General Chat About Cooling & Overheating

Moderator: phpBB2 - Administrators

Post Reply
reedreed
Newbie
Newbie
Posts: 2
Joined: Tue Jul 24, 2018 10:43 pm

4.6 operating temp.

Post by reedreed » Sat Aug 25, 2018 11:02 pm

Hi, all! Is there anyone here who runs on 4.6 with 14CUX hotwire installed in RRC with standard cooling system? I've swapped my 4.2 with 4.6 and since that I've got operating temp a little bit higher than it was before. In the same outside conditions it runs about 95 C degrees with brand new standard radiator installed. Aslo I tried 74C termostat but no changes. I'm not sure is it normal or not and what kind of upgrades should I tried to get it cooler. Any thoughts would be appreciated.



unstable load
Top Dog
Top Dog
Posts: 1179
Joined: Mon May 04, 2009 6:53 am

Re: 4.6 operating temp.

Post by unstable load » Sun Aug 26, 2018 5:57 am

By definition, a 4.6 will produce more heat than the 4.2, so maybe you need to look at a bigger capacity radiator. If there is a core available with more rows or a purpose made one if it comes to that.
I assume your pump is in good order?
Cheers,
John

DaveEFI
Forum Contributor
Forum Contributor
Posts: 3964
Joined: Fri Feb 26, 2010 4:27 pm
Location: SW London, UK

Re: 4.6 operating temp.

Post by DaveEFI » Sun Aug 26, 2018 8:06 am

In my experience, RV8s do tend to run hotter than the thermostat says if idling on a hot day or in slow moving traffic. The gauge on my SD1 has 100C as the mid way point, so not unreasonable that it should read that on occasion. When cruising with plenty airflow through the rad, it reads about the thermostat temp, 88C. If you did want it cooler at very slow speeds, you'd need to fit a big electric fan.
Dave
London SW
Rover SD1 VDP EFI
MegaSquirt2 V3
EDIS8
Tech Edge 2Y

SimpleSimon
Knows His Stuff
Knows His Stuff
Posts: 589
Joined: Mon Apr 25, 2011 10:36 pm
Location: SE England

Re: 4.6 operating temp.

Post by SimpleSimon » Mon Aug 27, 2018 11:41 pm

How are you reading these temps? did you change the fuel map with the upgrade it may be just running leaner if the answer is no :wink:
TVR Chimaera RV8 Serp & Megasquirt MS3X

reedreed
Newbie
Newbie
Posts: 2
Joined: Tue Jul 24, 2018 10:43 pm

Re: 4.6 operating temp.

Post by reedreed » Wed Aug 29, 2018 12:04 am

I'm reading the temp by Rovergauge and my 14CUX is managed by Tornado chip

garrycol
Getting There
Getting There
Posts: 307
Joined: Thu Jul 16, 2015 2:47 pm
Location: Canberra, Australia

Re: 4.6 operating temp.

Post by garrycol » Wed Aug 29, 2018 1:47 am

I replaced the 3.5 in my 101 with a 4.6 and used the thermostat out of the 3.5 and the 4.6 ran at the same temp measured on the dash as the 3.5.

DaveEFI
Forum Contributor
Forum Contributor
Posts: 3964
Joined: Fri Feb 26, 2010 4:27 pm
Location: SW London, UK

Re: 4.6 operating temp.

Post by DaveEFI » Wed Aug 29, 2018 7:43 am

I get slightly more consistent readings from the CTS on MegasSquirt than from the dash gauge with sensor beside the thermostat.
Dave
London SW
Rover SD1 VDP EFI
MegaSquirt2 V3
EDIS8
Tech Edge 2Y

Post Reply

Return to “Cooling Area”