Engine problems

General Chat About Engine Build

Moderator: phpBB2 - Administrators

Post Reply
paulsv8manta
Helpful or Confused
Helpful or Confused
Posts: 110
Joined: Sun Nov 29, 2009 6:09 pm
Location: Eastleigh

Engine problems

Post by paulsv8manta » Mon Sep 03, 2018 11:36 pm

Well I've finally got the car taxed and insured!
Spent Sunday and today putting some miles on the engine and them dam gremlins have raised their heads!
1) speedo has stopped working.
2) When i accelerate the engine is great but as soon as i ease off the accelerator pedal in any gear, the engine starts to judder and its worse in low gear. (Mentioned this in the previous post)
3) Now comes the scary problem, when I turn over the engine there is a loud knocking from the engine which disappears as soon as it fires up, and i've noticed a puff of blue smoke out of the exhaust!

I have a dreadful feeling I will have to tear down the engine, feeling totally gutted at the moment.



paulsv8manta
Helpful or Confused
Helpful or Confused
Posts: 110
Joined: Sun Nov 29, 2009 6:09 pm
Location: Eastleigh

Re: Engine problems

Post by paulsv8manta » Thu Nov 15, 2018 8:25 am

The good news about the knocking was the starter motor had become loose. And the Speedo cable had snapped in the Speedo unit.

User avatar
ChrisJC
Top Dog
Top Dog
Posts: 4586
Joined: Mon Nov 20, 2006 1:13 pm
Location: Northants / Cambs
Contact:

Re: Engine problems

Post by ChrisJC » Thu Nov 15, 2018 6:38 pm

Hey that's good news!

Chris.
--
Series IIA 4.6 V8
R/R P38 4.6 V8

Post Reply

Return to “Engines Area”