1982 SD1

What Do You Drive? Tell Us Here.
V8 Only Please,

Moderator: phpBB2 - Administrators

ged
Gold Member
Gold Member
Posts: 650
Joined: Tue Feb 10, 2009 2:09 pm
Location: North Wales via NZ
Contact:

Post by ged » Sat Apr 28, 2012 7:10 pm

Robrover wrote:Looks great Ged, which cam did you change over to? Ever had it on a dyno?

Thanks Robrover. :D

Cam's a stump puller, but with the rockers I get approx 0.020" more lift. I did want a Tornado but they aren't available at the moment. However I'm pleased with the outcome (for now). It pulls like a train & I have to keep a careful eye on the revs as it's easy to rev past 6000rpm.

As for rolling roads no I haven't.
I'm defo old school so I read the plugs for mixture, same with the timing (see how it pulls at different amounts of advance without pinking & how willing it is to rev).

Regards Ged



ged
Gold Member
Gold Member
Posts: 650
Joined: Tue Feb 10, 2009 2:09 pm
Location: North Wales via NZ
Contact:

Post by ged » Sat Apr 28, 2012 7:25 pm

bigaldart wrote:Ged,

Looks great, would love to know more about the rocker gear, construction, materials, bearings used, any chance of making another set :)

I would really like to get some insight, might even consider making some ourselves.

Keep up the good work

Alan
Thanks AL,

Much appreciated! :D

As for the rest leave it with me & I'll I let you know.

Regards Ged

Jono FD3
Knows His Stuff
Knows His Stuff
Posts: 408
Joined: Mon Apr 02, 2007 9:38 pm
Location: Milford Haven
Contact:

Post by Jono FD3 » Sat Apr 28, 2012 8:50 pm

top work matey, love the rocker setup you have done..... I enjoy tinkering and fabricating things, but that is way out my league!!

jono

mgbv8
Gold Member
Gold Member
Posts: 5326
Joined: Sat Nov 18, 2006 7:57 pm

Post by mgbv8 » Sat Apr 28, 2012 11:00 pm

A very nice Job Ged!!

Well done mate :)

ged
Gold Member
Gold Member
Posts: 650
Joined: Tue Feb 10, 2009 2:09 pm
Location: North Wales via NZ
Contact:

Post by ged » Wed May 09, 2012 6:54 pm

Thank's fella's

Regards Ged

ged
Gold Member
Gold Member
Posts: 650
Joined: Tue Feb 10, 2009 2:09 pm
Location: North Wales via NZ
Contact:

Re: 1982 SD1

Post by ged » Sun Apr 14, 2019 6:34 pm

I've not updated this for a while.
Car's been sat unloved in the garage for over 4 years. Anyway it's been long over due to go back on the road.
All fluids have been changed but it's still covered in dust including the inside because I left the window open. :roll:
I'll get it cleaned up & MoT'd in the next 2 weeks. Anyway here's a short video.

Image20190414_132718 by Ged Sant, on Flickr

Post Reply

Return to “Your Cars”