4.0 V8 won't rev

General Chat About Engine Build

Moderator: phpBB2 - Administrators

Post Reply
alanius
Newbie
Newbie
Posts: 20
Joined: Wed Aug 04, 2010 7:26 pm

4.0 V8 won't rev

Post by alanius » Mon May 13, 2019 6:18 pm

Hello,

I have a 4.0 V8 out of a P38 that will not rev over 1800 - 1900rpm after some work we've done, engine sits in a Defender and coupled to a 3.9 V8 auto gearbox.
Engine ran okish before, but cam had serieous wear and the wiring loom was modified badly so had te be removed.

We installed:
- new kent camshaft H180
- new lifters
- new timing chain and gears
- new plugs
- new oil pump rotors
- installed a new stand alone motormanagement (uses only a MAP sensor, crank sensor, air temp, TPS and watertemp)
I use this on all our other V8's and works great!

Everything fitted and installed like it should be:
- tapped pre load set correctly
- special lubricant for the camshaft
- camshaft gear and crank gear lined up with the 'dots' on the gear. turned a coulple of times and still matches so all fine

cranked the engine so we have oil pressure and then fired it up. It runs fine on idle and starts direct. But when you give throtlle he doesn't sound "aggressive" at all (like a V8 should do) and you can't go over 1800 - 1900 rpm.

I've done allready a lot to figure out what this can be, never had it before, but I have no idea at this point:
- changed the crank sensor
- checked the crank and camshaft gear - timing
- checked all values when the engine idles and all sensors give perfect values
- checked the timing if it changes when you give throttle, also fine
- I used some start pilot when the engine idles to try to rev the engine past the 1800 - 1900 rpm. BUT nothing happens, the rpm will not increase at all.
- fuel pump is the same and is untouched so should be fine.

Who knows what I can test - do more to solve this problem?

Thanks in advance!
Regards
Alain



User avatar
ChrisJC
Top Dog
Top Dog
Posts: 4605
Joined: Mon Nov 20, 2006 1:13 pm
Location: Northants / Cambs
Contact:

Re: 4.0 V8 won't rev

Post by ChrisJC » Mon May 13, 2019 7:36 pm

Swap in a different MAF if you have access to one.
And check fuel pressure in the fuel rail.
Chris.
--
Series IIA 4.6 V8
R/R P38 4.6 V8

minorv8
Knows His Stuff
Knows His Stuff
Posts: 493
Joined: Thu Nov 23, 2006 5:10 am

Re: 4.0 V8 won't rev

Post by minorv8 » Tue May 14, 2019 5:35 am

Sounds like some sort of rev limiter or locked timing issue. I had similar problem but on higher revs, around 4700 rpm. I have an older Haltech E6X ECU where you have some adjustability for crank sensor (gain/filter). Basically the setting is trial and error, in my case more on the error side. It felt like a hard cut rev limiter. Anyway, it was a simple case of changing the setting and it fixed it.

Or faulty ECU ?

alanius
Newbie
Newbie
Posts: 20
Joined: Wed Aug 04, 2010 7:26 pm

Re: 4.0 V8 won't rev

Post by alanius » Wed May 15, 2019 11:10 am

I can lock the timing but unfortunatly that is 'unlocked'.

Intried a different MAP sensor with no result.

Any other ideas?

DaveEFI
Forum Contributor
Forum Contributor
Posts: 4060
Joined: Fri Feb 26, 2010 4:27 pm
Location: SW London, UK

Re: 4.0 V8 won't rev

Post by DaveEFI » Wed May 15, 2019 11:53 am

Which engine management? Most have software which would tell you if a sensor was down.
Dave
London SW
Rover SD1 VDP EFI
MegaSquirt2 V3
EDIS8
Tech Edge 2Y

Post Reply

Return to “Engines Area”